Healthcare Hashtag Project and Public Website loading slow
Incident Report for Symplur
Resolved
This incident has been resolved.
Posted Oct 11, 2019 - 12:00 PDT
Update
We are continuing to investigate this issue.
Posted Oct 11, 2019 - 10:19 PDT
Investigating
We are currently investigating this issue of slow loading of pages.
Posted Oct 11, 2019 - 10:18 PDT
This incident affected: Public Website and Healthcare Hashtag Project.